Why does my picture keep freezing or breaking into squares?

This may be more noticeable on HD channels, however it’s best to first identify whether the problem is present on just one channel or on all channels.

If you have a Netbox or iBox:

If the problem is present on one channel only:

If you are subscribed to an additional Melita television outlet, identify the channel and check whether the problem is the same on both outlets.

  • If the channel is freezing/pixelated on both outlets, this could mean that there is a general problem on that particular channel.
  • If the channel is freezing/pixelated on one outlet only or you have no additional television outlets to check from, confirm that the metal connector on the coaxial cable is securely connected to the IN port at the back of the Melita Netbox/iBox HD.

  • Please also check that the same coaxial cable is securely connected to the splitter.
  • Confirm that the HDMI cable is securely connected to both ends. You can also test by swapping the HDMI port on your television set.

  • Reboot the Melita Netbox/iBox HD by pressing the power button on the Melita HD remote control.

If the problem is present on multiple/all channels:

  • Confirm that the metal connector on the coaxial cable is securely connected to the IN port at the back of the Melita HD Box.

  • Please also check that the same coaxial cable is securely connected to the splitter.
  • Confirm that the HDMI cable is securely connected to both ends. You can also test by swapping the HDMI port on your television set.

  • Press the Menu button from the Melita HD remote control.

  • Press OK on Setup and diagnostics.

  • Go to Automatic Digital Channel Tuning-in.
  • Press OK on Reception information. The below is some information you should look out for:

  • Strength: This indicates the signal strength on the Melita HD Box.
  • Quality: This indicates the quality of the signal. It should always be displayed as 100%.
  • SNR: The Signal to Noise Ratio should not be lower than 33.0dB.
  • BER: The error register should look similar to 0.000 (10E-4).

If you have a Digibox HD:

Please confirm that the metal connector on the coaxial cable is securely connected to the Cable In port at the back of the Melita Digibox HD.

If the problem perists please perform a factory default by clicking here.


Still need help? Our support team is waiting to help you. Ask them now